UNE NOUVELLE VERSION D'INFOBIDOUILLE EST EN LIGNE CLIQUEZ-ICI POUR LA VISITER

Microsoft Windows NT 3.1

Question sécurité, Microsoft n'est décidément pas très à la fête ces derniers jours... En effet, après la révélation d'une faille de sécurité touchant toutes les versions d'Internet Explorer depuis la 6, et qui serait à l'origine d'attaques importantes contre Google, c'est une faille de Windows qui fait désormais parler d'elle, en raison de son grand âge : elle touche toutes les versions 32 bits de Windows depuis... 1993 !

Cette longévité exceptionnelle s'explique par le fait que la faille touche un composant Windows qui évolue très peu et qui n'est quasiment plus utilisé : la NTVDM (Virtual DOS Machine), un composant qui assure la rétro-compatibilité des Windows entièrement 32 bits avec les applications 16 bits. Mais ce côté désuet ne la rend pas pour autant moins dangereuse, puisque cette faille permet de corrompre le noyau du système et d'obtenir les droits administrateur depuis un simple compte utilisateur...

Heureusement, cette faille a le bon goût d'être très facile à combler sur les versions récentes de Windows, en attendant l'arrivée d'un patch officiel. En effet, depuis Windows 2003, il existe une stratégie de groupe permettant de bloquer l'utilisation de cette machine virtuelle. Ce blocage peut être activé via l'éditeur de stratégie de groupe sur les versions professionnelles de Windows (Configuration ordinateur\Modèles d'administration\Composants Windows\Compatibilité des applications\Empêcher l'accès aux applications 16 bits). Les utilisateurs de versions familiales pourront pour leur part mettre en place ce blocage en positionnant à 1 la clé registre HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\AppCompat\VDMDissallowed.

Notez également que les versions 64 bits de Windows sont épargnées par cette faille, Microsoft ayant abandonné la rétro-compatibilité 16 bits dans ces versions.

Posté par Matt le 22/01/2010 à 12h26
3 commentaires
Source : Tom's Hardware

Mais pour les Windows XP SP2 ?

Posté par Ptit_boeuf le 22/01/2010 à 14h11 - Citer

J'aurais tendance à dire que XP SP2 est considéré comme postérieur à Windows 2003.
Tu as regardé dans gpedit.msc si tu as l'option ?

Posté par Matt le 22/01/2010 à 20h13 - Citer

Ouaip c'est bon

Posté par Ptit_boeuf le 23/01/2010 à 09h39 - Citer

Nom : 
Code de vérification : vingt-huit + seize = (en chiffres)